注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

最后一只恐龙的武器库

我的技术库

 
 
 

日志

 
 

SQLite与.Net Framework 4.0的兼容性解决方案  

2011-04-12 10:40:54|  分类: 开发小技巧 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

最近在使用vs2010开发基于SQLite的应用程序时,发现会报出兼容性异常如下:

System.IO.FileLoadException: Mixed mode assembly is built against version ‘v2.0.50727′ of the runtime and cannot be loaded in the 4.0 runtime without additional configuration information.

困扰了很久,原来我们只需要添加应用程序配置文件,在configuration节点加入

<startup useLegacyV2RuntimeActivationPolicy="true">
<supportedRuntime version="v4.0"/>
<requiredRuntime version="v4.0.20506" />
</startup>

即可解决问题。这样做可以允许旧的应用程序绑定到新的版本之上。

  评论这张
 
阅读(3631)| 评论(1)
推荐 转载

历史上的今天

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2018